723156

Minutengenaue Zeitberechnung

Anforderung

Zeitaufwand

Berechnungen mit Uhrzeiten sind in Excel immer ein kleines Problem. Es gibt viele Tricks, die weiterhelfen können, aber kaum einer wird jeder Problemstellung gerecht. Hoch gehandelt wird hier die Einstellung "1904-Datumswert" im Registerblatt "Berechnen" des Menübefehls "Extras, Optionen". Tatsächlich verhindern Sie mit dieser Einstellung, daß Excel mit den ungeliebten Nummernzeichen (#) kapituliert. Außerdem kann das Programm dann auch mit negativen Zeitwerten rechnen. Das Ergebnis ist allerdings nicht immer korrekt. Ein Beispiel: Beginnt der Zeitraum um 22:00 Uhr abends und endet um 8:00 Uhr morgens, wird das Ergebnis "-14" Stunden wenig Freunde finden.

Als praktikable und sichere Lösung dieses Problems bietet sich eine Formel an, die aus dem Zeitwert die Minutenzahl bildet und diese als Dezimalzahl ausgibt. Die Zelle, in der das Ergebnis ausgegeben wird, müssen Sie also per "Format, Zelle" statt mit einem Zeit- mit einem Zahlenformat belegen. Als Ergebnis erhalten Sie die genaue Minutenzahl. Sie läßt sich jederzeit wieder durch 60 dividieren, um die Stundenzahl zu ermitteln. Die betreffende Zeile lautet:=WENN(B2<A2;(STUNDE((B2-A2)+1)*60)+(MINUTE((B2-A2)+1));WENN(B2=A2;1440;(STUNDE(B2-A2)*60)+(MINUTE(B2-A2))))Hier steht die Anfangszeit in der Zelle "A2" und der Schlußpunkt in "B2".

PC-WELT Marktplatz

723156