235261

Mehrere WENNs verschachteln

Gehen wir jetzt eine Stufe weiter: Mehrere WENN-Funktionen sind ineinander verschachtelt. Wenn A1=5 ist, soll Aktion A durchgeführt werden, so weit, so gut. Tritt A nicht ein, soll Fall B eintreten. Auch gut. Was machen Sie aber nun, wenn Sie auch noch prüfen wollen, ob A1=7 ist, dann nämlich soll C eintreten. Konkret heißt das: WENN A1=5 DANN Aktion A SONST WENN A1=7 DANN Aktion C SONST Aktion B. In den SONST-Bereich der ersten WENN-Funktion haben wir eine zweite WENN-Funktion eingebettet.

Das Spiel lässt sich noch weiter treiben: In den SONST-Bereich der zweiten WENN-Funktion ließe sich noch ein drittes WENN einbetten. Zugegeben: Dann wird's richtig kompliziert. Beachten müssen Sie bei der Verschachtelung vor allem die Klammersetzung: =WENN(A1=5;"Aktion A";WENN(A1=7; "Aktion C";"Aktion B"))

Natürlich können Sie eine zweite WENN-Funktion auch in den DANN-Bereich der ersten Funktion einbauen. Beispiel: Wenn A1=5, dann soll überprüft werden, ob B1=10 ist, und wenn das ebenfalls zutrifft, soll der Text „Treffer!“ angezeigt werden, wenn A1=5, aber B1 nicht gleich 10, dann soll „Niete“ angezeigt werden, und trifft beides nicht zu, soll gar nichts erscheinen. Noch einmal anders erklärt: Ist A1=5, dann stürzen wir uns auf die Zelle B1. Ist B1=10, dann erhalten wir einen „Treffer!“, falls nicht, dann eine „Niete“.

Beide Bedingungen sind erfüllt: A1 stimmt, B1 stimmt – macht einen "Treffer!"
Vergrößern Beide Bedingungen sind erfüllt: A1 stimmt, B1 stimmt – macht einen "Treffer!"
© 2014

Und wenn A1 nicht 5 ist, erhalten wir gar nichts. Konkret sieht das dann so aus: WENN A1=5 DANN WENN B1=10 DANN „Treffer!“ SONST „Niete“ SONST „nichts“ Und in eine richtige Formel gepackt: =WENN(A1=5;WENN(B1=10;"Treffer!";"Niete");"")

Die zwei Anführungsstriche hintereinander ("") bedeuten, dass in diesem Fall die Zelle einfach leer bleibt.

PC-WELT Marktplatz

235261