235709

Komplexe Funktionen: ANZAHL, RUNDEN, MITTELWERT, Verschachtelungen

02.06.2018 | 08:52 Uhr |

Datenauswertung anhand eines einfachen Beispiels
Vergrößern Datenauswertung anhand eines einfachen Beispiels
© 2014

SUMME ist natürlich kein sehr spektakulärer Vertreter der Funktionen. Die vielfältigen Möglichkeiten von Funktionen zeigen sich erst an einem etwas komplexeren Beispiel: Nehmen wir an, der Spielverein Obersee veranstaltete einen Spielnachmittag, bei dem alle Teilnehmenden Punkte sammelten. Zur Auswertung trägt Organisator Egon Müller zuerst Jahrgang, Name, Vorname und Geschlecht in eine Tabelle ein und in der letzten Spalte die erreichte Punktzahl.

ANZAHL zählt die Anzahl Einträge in einer Spalte. MITTELWERT ermitttelt den Durchschnitt.
Vergrößern ANZAHL zählt die Anzahl Einträge in einer Spalte. MITTELWERT ermitttelt den Durchschnitt.
© 2014

An den folgenden Beispielen sehen Sie, wie einfach die Auswertung solcher Datensätze mit den von Excel bereitgestellten Funktionen ist.

Funktion ANZAHL

Leider hat Egon Müller vergessen, wie viele Leute am Spielnachmittag teilnahmen. Zugegeben: Wenige Teilnehmer könnte Müller einfach von Hand zählen, aber er benutzt lieber die Funktion ANZAHL. Müller möchte, dass die Anzahl der Teilnehmer in Zelle I2 erscheint. Als Bezug gilt für die Formel die Position des ersten und des letzten Wertes, der für ihn wichtig ist, im Beispiel A2 und A12. Die korrekte Formel muss also bei aktivierter Zelle 12 so aussehen: =ANZAHL(A2:A12). Das Ergebnis ist 11.

Funktion MITTELWERT

Als Nächstes will Müller in Zelle I3 wissen, wie alt die Teilnehmenden im Durchschnitt sind. Dafür eignet sich die Funktion MITTELWERT. Sie ermittelt den Durchschnitt der eingetragenen Daten. In Spalte A steht der Jahrgang der Mitspieler, folglich muss die Formel =MITTELWERT(A2:A12) lauten. Das Resultat ist leider unschön: 1969.81818.

=RUNDEN(I4;2), das Ergebnis 1969,82.
Vergrößern =RUNDEN(I4;2), das Ergebnis 1969,82.

Funktion RUNDEN

Dem begegnet Müller mit der Funktion RUNDEN. Im Gegensatz zum MITTELWERT verlangt RUNDEN einen so genannten Parameter, also eine weitere Anweisung. In diesem Fall ist es die Anzahl Stellen hinter dem Komma, die angezeigt werden sollen. Hat eine Funktion wie in diesem Fall mehr als einen Parameter, werden sie durch Strichpunkte (;) voneinander getrennt.

Lese-Tipp: Die besten Tipps für Excel

Manchmal ist es ratsam, den gerundeten Wert in einem separaten Feld (im Beispiel in Zelle J4) darzustellen, die Formel bezieht sich dann auf die Zelle, in der das ungerundete Resultat steht. Beim Runden auf zwei Stellen nach dem Komma ist der zusätzliche Parameter 2, die Formel in J4 lautet =RUNDEN(I3;2), das Ergebnis 1969,82.

Drei pfiffige Excel-Tools und eine Excel-Alternative

Diese Form ist in unserem Beispiel allerdings nicht sehr schön, weil jetzt für dasselbe Resultat zwei Zellen benötigt werden (I3 und J4). Abhilfe schafft ein geschachtelter Befehl, in dem die Funktionen MITTELWERT und RUNDEN kombiniert werden. Jetzt wird es etwas komplizierter: Die erste Funktion RUNDEN bezieht sich auf die zweite Funktion MITTELWERT, die sich wiederum auf bestimmte Zellen bezieht.

Excel kann mehrere Funktionen verschachteln
Vergrößern Excel kann mehrere Funktionen verschachteln
© 2014

Dementsprechend müssen Sie in der Formel Klammern setzen. Im Beispiel lautet die Formel =RUNDEN(MITTELWERT(A2:A12);0). Wenn mit dem Parameter 0 gerundet wird, also keine Nachkommastellen zugelassen sind, steht in Zelle I3 die Zahl 1970, weil 1969,81818 aufgerundet wird.

10 Tricks für schnelleres Arbeiten mit Microsoft Excel

FORMELTEXT: Formeln als Text wiedergeben

FORMELTEXT: Formeln als Text wiedergeben
© Vierfarben Verlag

PC-WELT Marktplatz

0 Kommentare zu diesem Artikel
235709