1962889

Rundungs- und Formatierungsfunktionen

03.08.2019 | 09:33 Uhr |

Die Funktion TEXT formatiert eine Zahl und wandelt das Ergebnis in einen Text um. Fast alle Zahlenformate, die sich über das Dialogfeld Zellen formatieren einstellen lassen, können Sie ebenso mit dieser Funktion erzeugen. Somit können Sie mit dieser Funktion unter anderem auch runden. Excel bietet eine ganze Reihe weiterer Rundungsfunktionen, die auf den ersten Blick oft gleiche Ergebnisse liefern, aber trotzdem feine Unterschiede haben, die man nicht außer Acht lassen darf. Die Funktionen RUNDEN, FEST und DM runden nach einer beliebigen Anzahl Stellen auf oder ab. Ab 0,5 wird stets aufgerundet. Sie liefern das identische Ergebnis, außer dass FEST und DM Texte liefern. DM liefert zusätzlich das gemäß Ländereinstellung aktuell gültige Währungssymbol. Bei DM setzt die Multiplikation mit 1 voraus, dass das Währungssymbol mit einer Textfunktion abgeschnitten wurde. Die nicht dokumentierte Funktion USDOLLAR macht exakt dasselbe.

Die Funktionen ABRUNDEN, KÜRZEN, UNTERGRENZE und GANZZAHL runden nach unten ab. Bei ABRUNDEN und KÜRZEN kann eine beliebige Anzahl Stellen vorgegeben werden. Enthält das Argument Anzahl_Stellen eine negative Zahl, kann auf volle Zehnerpotenzen (vor dem Komma) gerundet werden. Mit UNTERGRENZE kann man noch feiner justieren, da auf das nächstliegende Vielfache einer beliebig definierbaren Schrittweite abgerundet werden kann. GANZZAHL schneidet einfach alle Nachkommastellen ab. Die gleiche Funktion mit zwei G, also GGANZAHL führt die völlig banale Prüfung =(A1>=B1)*1 durch. QUOTIENT ist keinen Deut nützlicher und liefert lediglich den ganzzahligen Teil einer Division, genau wie GANZZAHL(Zahl1/Zahl2) AUFRUNDEN und OBERGRENZE runden nach oben auf und funktionieren ansonsten wie ihre Pendants zum Abrunden. VRUNDEN rundet auf das beliebige Vielfache einer Zahl auf oder ab und macht damit das Gleiche wie =RUNDEN(Zahl/Vielfaches;0)*Vielfaches VRUNDEN liefert stets entweder das Ergebnis von UNTERGRENZE, falls abgerundet wird, oder das von OBERGRENZE, falls aufgerundet wird. GERADE und UNGERADE runden positive Zahlen auf die nächste gerade bzw. ungerade Zahl auf und im negativen Bereich ab. ABS liefert den Absolutwert einer Zahl.

Beispiele zu Rundungsfunktionen

Wert

Formel

Ergebnis

2,336

=TEXT(Wert;"#.##0,00")

2,34

2,336

=DM(Wert;2)

2,34 €

2,336

=FEST(Wert;2)

2,34

2,336

=ABRUNDEN(Wert;2)

2,33

2,336

=ABS(Wert)

2,336

2,336

=AUFRUNDEN(Wert;2)

2,34

2,336

=GANZZAHL(Wert)

2

2,336

=GERADE(Wert)

4

2,336

=KÜRZEN(Wert;2)

2,33

2,336

=OBERGRENZE(Wert;0,05)

2,35

2,336

=VRUNDEN(Wert;0,05)

2,35

2,336

=RUNDEN(Wert;2)

2,34

2,336

=UNGERADE(Wert)

3

2,336

=UNTERGRENZE(Wert;0,05)

2,3

12345

=RUNDEN(Wert;-3)

12000

PC-WELT Marktplatz

1962889