Excel-Tipps

5 Excel-2007-Formeln, die fast jeder braucht

Freitag den 06.05.2011 um 11:17 Uhr

von Thorsten Eggeling

Microsoft Excel 2007 DE Win
Microsoft Excel 2007 DE Win
Preisentwicklung zum Produkt
Anzahl der Werktage ab einem Startdatum

Für einen Fälligkeitstermin benötigen Sie das Datum nach einer bestimmten Anzahl von Arbeitstagen. Ein Projekt startet beispielsweise am 01.06. und soll nach 14 Arbeitstagen beendet sein. Sie möchten jetzt unter Berücksichtigung der Wochenenden das End-Datum erfahren. Dazu dient in Excel 2007 die Formel

=ARBEITSTAG("01.06.2011";14)

die den 21.06.2011 ausgibt. Beachten Sie, dass dieses Datum, den Tag angibt, der auf den letzten tatsächlichen Arbeitstag folgt. Wenn Excel 2007 zusätzlich noch Feiertage beachten soll, sieht die Formel so aus:

=ARBEITSTAG("01.06.2011";14;E2:E14)

In diesem Beispiel muss sich eine Liste mit Datumsangaben zu Feiertagen im Zellbereich E2 bis E 14 befinden.

Werktage zwischen zwei Daten

Sie benötigen die Anzahl von Arbeitstagen zwischen zwei Datumsangaben.
Die Formel

=NETTOARBEITSTAGE("01.06.2011"; "24.06.2011")

liefert als Ergebnis 18 Tage. Excel 2007 schließt hier den ersten und letzten Tag in das Ergebnis ein, diese werden also mitgezählt. Auch die Funktion NETTOARBEITSTAGE kann Feiertage berücksichtigen. Mit der Formel

=NETTOARBEITSTAGE("01.06.2011";"24.06.2011";E2:E14)

beispielsweise, klammern Sie die Daten im Bereich E2 bis E14 von der Berechnung aus.

Excel-Funktionen für Profis

So heben Sie in Excel Werte automatisch hervor
So heben Sie in Excel Werte automatisch hervor

Bewegliche Feiertage berechnen

Für die Kalkulation von Arbeitstagen oder einen Kalender benötigen Sie die beweglichen Feiertage. Diese leiten sich alle vom Termin des Osterfestes ab. Der Ostersonntag 2011 lässt sich mit der Formel

=DM((TAG(MINUTE(2011/38)/2+55)&".4."&2011)/7;)*7-6

berechnen. Die Ergebniszelle müssen Sie als „Datum“ formatieren, damit der Wert richtig angezeigt wird. Für die anderen Feiertage müssen Sie dann nur noch Tage abziehen oder hinzuzählen, für Rosenmontag beispielsweise -48 Tage und für Pfingstsonntag +49 Tage.

10 Excel-Tipps für Profis

Werte in Excel 2007 richtig runden

Für das kaufmännisch korrekte auf- und abrunden bietet Excel 2007 die Funktion RUNDEN. Die Formel =RUNDEN(1234,454;2) beispielsweise ergibt 1234,45. =RUNDEN(1234,455;2) ergibt 1234,46. Mit einem Trick verwenden Sie die RUNDEN-Funktion auch fürs Runden auf Zehnerpotenzen: Geben Sie die Anzahl der Stellen vor dem Komma, auf die Sie runden möchten, ein, und setzen Sie ein Minuszeichen davor. So rundet etwa =RUNDEN(123,456;-2)" die Zahl 123,456 auf 100.

Minimal- und Maximal-Wert ermitteln

Formeln lassen sich auch für die Auswertung und Formatierung einer Tabelle nutzen. Ein Anwendungsgebiet dafür ist die bedingte Formatierung. Damit können Sie beispielsweise den kleinsten und größten Wert in einer Spalte farblich hervorheben.
Dazu klicken Sie den gewünschten Wert an, gehen auf die Registerkarte „Start“ und klicken in der Gruppe „Formatvorlagen“ auf „Bedingte Formatierung“ und „Neue Regel“. Unter „Regeltyp auswählen“ klicken Sie auf „Formel zur Ermittlung der zu formatierenden Zellen verwenden“. In das Feld unter „Werte formulieren, für die diese Formel wahr ist“ geben Sie eine Formel ein. Für die abgebildete Beispieltabelle etwa =E2=MAX($E$2:$E$8). Nach einem Klick auf „Formatieren“ wählen Sie eine passende Farbe aus. Wiederholen Sie diesen Schritt. Geben Sie dabei die Formel =E2=MIN($E$2:$E$8) ein und wählen Sie eine andere Farbe für die Formatierung. Ziehen Sie in der Zelle E2 das Ausfüllkästchen nach unten, damit Excel 2007 die Regel auf die gewünschten Zellen in der Spalte anwendet.

Pfiffige Tabellen mit Excel 2007

Freitag den 06.05.2011 um 11:17 Uhr

von Thorsten Eggeling

Kommentieren Kommentare zu diesem Artikel (0)
838005