16014

Sicherheitslücke in PunBB entdeckt

31.10.2006 | 12:30 Uhr |

Über eine Sicherheitslücke in der freien Diskussions-Foren-Software PunBB können Angreifer eigenen PHP-Code einspeisen und ausführen.

Die Schwachstelle entsteht während der Registrierung eines neuen Benutzers in der Datei "register.php". Eingaben über den Parameter "language" werden nicht ausreichend überprüft und erlauben die Einspeisung von lokalen Dateien. Auf diese Weise kann ein Angreifer eigenen PHP-Code einspeisen und auf dem betroffenen System ausführen. Die Sicherheitslücke wird mit der neusten Version 1.2.14 geschlossen, die auf der Website des Projekts zum Download zur Verfügung steht. (twi)

Sie interessieren sich für IT-Security? Über aktuelle Sicherheitslücken informieren Sie die Security-Reports von tecCHANNEL in Kooperation mit Secunia. Sie können diesen Dienst auch als kostenlosen Newsletter oder als tägliche tecCHANNEL Security Summary abonnieren. Premium-Kunden haben zudem die Möglichkeit, sich bei hoch kritischen Lücken per Security Alert informieren zu lassen.

tecCHANNEL Shop und Preisvergleich

Links zum Thema IT-Sicherheit

Angebot

Bookshop

Bücher zum Thema

eBooks (50 % Preisvorteil)

eBooks zum Thema

Software-Shop

Virenscanner

0 Kommentare zu diesem Artikel
16014